Начало работы с PDT или поиск PHP IDE

Понял что использовать Dreamveawer больше не могу, поэтому начал присматриваться к мощным PHP IDE. Припомнил, что читал на Хабре статью про сравнение IDE для языка PHP. В принципе статья состоит практически из одной сравнительной таблицы, автор расшарил ее на гуглодоках. Была мысль использовать Zend Studio, но цена сразу же отмела эту мысль. Вообще нужно сказать, что хотя в сравнительной таблице довольно много разных IDE, но я считаю, что достоины внимания только три из них:

  1. Zend Studio
  2. Netbeans
  3. Eclipse

Как я уже сказал, Zend Studio стоит немалых денег, поэтому для меня остались только Netbeans и Eclipse. Я как человек не по наслышке знакомых с Flex, решил выбор в пользу Eclipse (Flex редактор построен на основе Eclipse).

Нужно отметить, что Eclipse как таковой это фреймворк для разработки модульных кроссплатформенных приложений. Поэтому ознакомившись и научившись работать с Eclipse для PHP, затем перейти на этот же IDE, допустим под Java не составит труда.

Воодушевившись всеми вышеперечисленным доводами, я начал настройку PDT.

Так как я в своих проектах люблю использовать Smarty, то сразу решил настроить в редакторе работу с ним. Погуглив сразу же нашел плагин для работы со Smarty в среде Eclipse.

Преступим к установке, для этого нужно скачать архив с файлами.

  • Для начала проверим, не ассоциируются ли .tpl (файлы шаблонов Smarty) файлы с какими-нибудь редакторами. Для этого идем в Window->Preferences->General->Content Types. Там заходим в Text и проверяем секции HTML и PHP Content Type. Если в этих секциях есть упоминания .tpl удаляем.
  • Идем в раздел Help->Install New Software
    Установка дополнения Smarty PDT
    Жмем «OK», убираем галочку «Group items by category» и видим только что добавленное дополнение.
  • Далее жмем кнопку «Next» несколько раз и видя окно предупреждения не переживаем и жмем «OK»
    Предупреждение
  • После этого перегружаем Eclipse кликнув на кнопку «Yes», или вручную просто закрыв и запустив IDE заново.
    Все плагин установлен.

Есть распространенная ошибка, которую активно обсуждают в wiki проекта на гулокоде, я и сам ее допустил.

А все оттого, что не зная о существовании плагина, я самостоятельно ассоциировал *.tpl файлы c обычным редактором.
Для решения проблемы делаем следующее:

  1. Удаляем установленный плагин Smarty. Для этого идем в Help->Install New Software и ищем ближе к правому нижнему углу ссылку «What us already installed?». Видим окно с тем, что установлено выбираем Smarty Feature, нажимаем на кнопку «Uninstall». Жмем далее, перезапускаем Eclipse.
  2. После запуска сразу идем в Window->Preferences->General->Editors->File Associations и удаляем там *.tpl.
  3. Теперь устанавливаем плагин заново, все должно работать.

Ну и пример как все выглядит в рабочем состоянии.

Ну а теперь самое время перейти к тестированию работы IDE, чего и вам желаю 🙂

7 thoughts on “Начало работы с PDT или поиск PHP IDE

  1. Привет из тви!
    Ты зря игноришь PhpEd — это ОЧЕНЬ КРУТАЯ IDE для PHP, правда.
    Из остальных мне импонирует NetBeans, но у него очень туманное будущее в связи с приобритением компании SUN гигантом Oracle.
    p.s.: Пишу сейчас обзор PhpEd если интересно, через пару дней он обязательно появится на моем блоге.

  2. Кстати, пиши, какой юзаешь двиг на блоге, или инфу о том, как комментировать, а то неприкольно до последней минуты гадать, распарсится ли ссылка в html или стоило сделать BBCode. А можно и предпросмотр сделать.

Добавить комментарий для Xo66uT Отменить ответ

Ваш e-mail не будет опубликован. Обязательные поля помечены *